酷笔记 > Magento2中文手册 > Magento 2.1.x 系统需求

Magento 2.1.x 系统需求

操作系统 (Linux x86-64)

Linux发行版如红帽企业Linux(RHEL),CentOS,Ubuntu,Debian,等等

内存需求

升级的应用程序和扩展你的Magento从Magento市场和其他来源获得需要多达2GB的RAM。如果您使用少于2GB内存的系统,我们建议您创建一个交换文件;否则,您的升级可能会失败。

Composer

最新的稳定版本

web服务器

  • Apache 2.2 or 2.4

  • nginx 1.8 (或最新稳定版本)

数据库

Mysql 5.6

Magento应用版本2.1.2后来与MySQL 5.7兼容。

MariaDB和Percona是兼容Magento因为我们支持MySQL 5.6的API。

PHP

7.0.0, 7.0.1 7.0.2 7.0.3 7.0.4 7.0.5 7.0.6–7.0.x 7.1.x
5.6.0–5.6.4 5.6.5–5.6.x
5.5.x

PHP文件:CentOS, Ubuntu

需要的PHP扩展:

  • bc-math
  • curl
  • gd, ImageMagick 6.3.7 (or later) or both
  • intl
  • mbstring
  • mcrypt
  • mhash
  • openssl
  • PDO/MySQL
  • Simplexml
  • soap
  • xml
  • xsl
  • zip
  • 仅PHP 7: